ESXI 6.5 在Intel NUC下出现SSD传输缓慢问题

2016年的时候,VMware释出了他们ESXI的6.5版本,过了半年,我准备在NUC上测试一次这个最新版本,不过出现了出乎意料的情况,试着上传30GB的虚拟机竟然耗费了整整4个小时,而且还失败了。测试了5块SSD,其中2块存在这样的问题,但是出现这样问题的SSD在NUC上安装Windows系统又没有出现任何问题。

软件平台:VMwaer ESXI 6.5  r4564106
硬件平台:Intel NUC5i3RYH(服务器) / Intel NUC6i3SYH(服务器)

 

在故障机上查看ESXI日志可以看到频繁出现这样的内容:


由于连接性问题导致失去对卷 58aaeeb5-6d8a8510-9866-b8aeed7d39fb (datastore1) 的访问权。正在进行还原尝试,稍后将报告结果。
出现连接性问题后成功恢复对卷 58aaeeb5-6d8a8510-9866-b8aeed7d39fb (datastore1) 的访问权。


截图如下

推测传输缓慢与此有关。根据日志的内容来看,似乎像是出现了掉盘状况,不知道是否跟LPM(链路电源管理)有关,出现此故障的2块江波龙SSD均为SM2246的控制器,不过也有2块没有出现问题的SSD也是该主控并且同样是江波龙制造。综合上面Windows测试的结果来看,似乎这些SSD在Windows下没有问题,另外我也试着往这些SSD上安装ESXI 6.0,结果没有一块出现上述问题,即是说这些SSD都是好的。

不死心在Google上翻找,最终找到了这样文章,原帖是国外的一个站点,他们使用Sandisk的SSD时碰到了同样的问题,最终判定是驱动引起的问题,起因是由于VMware在其ESXI 6.5中导入了一个新的SATA驱动——vmw-ahci,这个新的驱动相比之前的驱动能够支持更多硬件,不过看起来有点小问题。文章同样给出了解决方法(原文地址)

安装6.0版本中通用的第三方Intel AHCI驱动并禁用vmw-ahci似乎就可以解决问题:

先验证下用于替代vmw-ahci的驱动是否已经存在于系统中

# esxcli software vib list | grep ahci
sata-xahci 1.39-1 VFrontDe CommunitySupported 2017-02-20
sata-ahci 3.0-22vmw.650.0.0.4564106 VMW VMwareCertified 2017-02-20
vmw-ahci 1.0.0-32vmw.650.0.0.4564106 VMW VMwareCertified 2017-02-20

然后禁用vmw-ahci

esxcli system module set --enabled=false --module="vmw_ahci"                

重启后你会发现磁盘明显变快,并且日志中的连接性错误不复存在。在WebUI中查看存储装置,发现驱动程序已经不是vmw-ahci,如下图


最后来说说这个vmw-ahci吧,原先ESXI<=6.0的时候所能支持的SATA控制器少是人尽皆知的(其自带的sata-ahci驱动仅识别部分SATA控制器),为此德国社区v-front.de释出了他们的解决方案,一个额外的驱动sata-xahci来识别所有标记自己为SATA控制器的硬件设备,并为这些设备加载系统自带的sata-ahci驱动。不过按照v-front.de对ESXI 6.5的发布介绍(原文)中可以看到,从该版本的ESXI开始,系统自带了一个新的驱动vmw-ahci,不同于以往的sata-ahci驱动,vmw-ahci默认会为所有标记自己为SATA控制器的硬件设备加载,也就是说从此ESXI不再挑SATA控制器,甚至其兼容范围会比Windows更广。虽然目前来说这个驱动还不够完善,但是这确实是一个重大的利好。

 


  请注意,本站的所有文章均要求阁下在转载时注明出处和原作者,阁下转载本站文章即表示阁下同意并遵守此规程,除非特别注明转载出处,否则文章即为其发布者所著。本站及文章作者保留文章的著作权并有权在阁下违反上述规程时予以追究。

本文链接地址: ESXI 6.5 在Intel NUC下出现SSD传输缓慢问题

3 Response(s)

  1. 我本奈何 says :

    2017年3月10日

    有的说 直接禁用就可以,也有的说需要 xahci ,2种我都试过
    然而 都失败了。
    其中一个 ssd 是 SanDisk Extreme PRO 480G (SanDisk SDSSDXPS)

    回复
    1. animefans_xj

      animefans_xj says :

      2017年3月10日

      是否需要是要看6.0及以前版本是否能够识别你的AHCI控制器的,如果先前版本能识别,那么就无需安装xahci,如果先前版本无法识别你的AHCI控制器,需要安装xahci来使得系统识别和使用你的ahci控制器的,则在6.5版本中禁用vmw_ahci前需要先安装xahci

      回复
    2. animefans_xj

      animefans_xj says :

      2017年3月10日

      按照文中提供的方法安装xahci和禁用vmw_ahci,在我的NUC和江波龙SSD上有效

      回复

发表评论

电子邮件地址不会被公开。 必填项已用*标注

*